改良智能MACD指标公式及源代码

作者:把手老师 01-28 来源:股市赢家网 点击:
TAG: MACD

 MACD图_副本.jpg

  指标的参数和系统自带的MACD指标差不多,但是通过颜色区分,看起来更直观。当零轴线上出现红柱并逐渐伸长,代表上涨势头在增强。当零轴线下出现白色的柱子并逐渐伸长,说明下跌势头在增强,当MACD两根平滑曲线形成金叉的时候,会出现红色箭头提示。

  指标公式文件:(请打开下面百度网盘链接下载)

        https://pan.baidu.com/s/1eTYodUE

 

  指标源码:(请先把代码复制粘贴到电脑txt文档清除格式,再重新复制粘贴在软件编辑框。) 

 

DIFIF1:=EMA(CLOSE,12) - EMA(CLOSE,26);

DEAEA1:=EMA(DIFIF1,9);

MACD1:=2*(DIFIF1-DEAEA1),STICK;

MACD2:=EMA(MACD1,3);

STICKLINE(MACD1>MACD2 AND MACD1>0,0,MACD1,1,0),COLORRED;

STICKLINE(MACD1>MACD2 AND MACD1<0,0,MACD1,1,0),COLORGREEN;

STICKLINE(MACD1<MACD2,0,MACD1,1,0),COLORCBCBC0;

STICKLINE(MACD1>=0 OR MACD1<=0,0,0,50,1),COLORWHITE;

DIFIF1,COLOR33FF33;

DEAEA1,COLORYELLOW;

MACD:MACD1,NODRAW,COLORMAGENTA;

强:IF(DIFIF1>=DEAEA1,DIFIF1,DRAWNULL),COLORRED,LINETHICK2;  

弱:IF(DEAEA1>=DIFIF1,DEAEA1,DRAWNULL),COLORFF9900,LINETHICK2; 

DRAWICON(CROSS(DIFIF1,DEAEA1),DEAEA1-0.02,1);

 
 
指标建立和调用如有疑问,请关注股市赢家网公众号,回复MACD查看教程。

    

 

 

 

如果觉得本帖内容有价值,请分享给你身边的朋友!